Si vous voyez un avertissement apt-key obsolète lorsque vous exécutez la mise à jour apt sur Ubuntu et que vous souhaitez le réparer, vous êtes au bon endroit

Dans cet article, je vous guide (et moi-même) tout au long du processus. Vous voyez, après avoir suivi les étapes pour installer TeamViewer sur Ubuntu, j’ai remarqué l’erreur suivante à chaque fois que j’exécute apt update:

W: https://linux.teamviewer.com/deb/dists/stable/InRelease: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for details.

Bien qu’indésirable, l’avertissement n’empêche pas la mise à jour ou la mise à niveau du système. Vous pouvez l’ignorer sans aucun effet néfaste et, pendant un jour ou deux, c’est ce que j’ai fait. Et si vous vous en tenez aux méthodes de mise à jour de l’interface graphique, vous n’entendrez pas du tout parler de l’erreur.

Mais c’est ennuyeux, et bon : l’avertissement s’affiche pour une raison. Bien que je ne vais pas entrer dans les raisons pour lesquelles apt key add a été déprécié ici (il y a quelques excellentes explications ailleurs sur le web) mais je vais vous montrer comment le résoudre.

Correction de l’erreur d’obsolescence Apt-Key

La correction de l’erreur de dépréciation apt-key sur Ubuntu peut être effectuée de plusieurs manières.

Méthode 1 : la manière sensée

La méthode recommandée de AskUbuntu est comme suit. Tout d’abord, ouvrez une nouvelle fenêtre de terminal, puis regardez à l’intérieur de votre ancien fichier apt-key en exécutant cette commande :

sudo apt-key list

Selon votre système, vous pouvez voir apparaître quelques entrées ou une véritable avalanche.

Faites défiler la liste avec soin. Faites attention à la façon dont les choses sont disposées. Recherchez la section qui mentionne le package répertorié dans l’avertissement initial (si vous voyez plusieurs avertissements, vous devrez répéter ces étapes pour chacun à son tour).

Dans mon cas, je cherche la clé liée à TeamVieweret ça ressemble à ça :

pub rsa4096 2020-01-29 [SC]
8CAE 012E BFAC 38B1 7A93  7CD8 C5E2 2450 0C12 89C0
uid [ unknown] TeamViewer Germany GmbH (TeamViewer Linux 2020) <support@teamviewer.com>

Copiez les 8 derniers caractères de la deuxième ligne – dans l’exemple ci-dessus, il s’agit 0C12 89C0 – et le convertir en un .gpg fichier à l’aide de la commande ci-dessous. N’oubliez pas de supprimer l’espace entre les 8 caractères et de spécifier un gpg nom de fichier correspondant au package auquel la clé est destinée.

Dans mon exemple, j’ai dû exécuter:

sudo apt-key export 0C1289C0 | sudo gpg --dearmour -o /etc/apt/trusted.gpg.d/teamviewer.gpg

Une fois que vous avez construit votre commande, appuyez sur enter … C’est tout ce que vous devez faire.

Lors de la prochaine exécution d’un apt update l’erreur de clé obsolète n’apparaîtra plus pour le dépôt que vous venez d’appliquer (bien que si vous avez plus d’un dépôt affecté, vous devrez répéter les étapes ci-dessus pour chacun).

Vous trouvez cette méthode trop impliquée ?

Méthode 2 : la méthode rapide

La méthode « recommandée » pour corriger les erreurs de dépréciation des clés apt sur Ubuntu est la méthode détaillée ci-dessus. Mais il existe une solution « rapide et sale ».

Bien que la méthode ci-dessous ait fonctionné, je dois souligner que a) votre kilométrage peut varier et b) ce n’est pas le intelligent moyen de résoudre ce problème car, selon les clés héritées de votre système, il pourrait compromettre la sécurité de votre système.

Si vous êtes heureux de jeter la prudence au vent, ouvrez un nouveau Terminal fenêtre et lancez :

cd /etc/apt

Suivie par:

sudo cp trusted.gpg trusted.gpg.d

Entrez votre mot de passe comme demandé et appuyez sur enter postuler.

Lors de votre prochaine course apt update l’erreur en question n’apparaîtra plus.

LAISSER UN COMMENTAIRE

S'il vous plaît entrez votre commentaire!
S'il vous plaît entrez votre nom ici